Q: Fitness App Shuts Down During Run

Hi everyone! I have a Nano 7th gen, and it recently developed a problem where, when using the Fitness app, it shuts down with about a minute left in the run. The iPod completely powers off--this isn't an issue with the app just crashing. I've power cycled off the iPod a few times, but it's still happening. It seems like the next step would be to restore the factory settings, but I'm hoping to avoid that because (1) I don't want to lose all of my saved runs, and (2) I don't want to have to recalibrate it again. Anyone else have a similar problem? Thanks!

iPod

Posted on Jan 12, 2014 10:44 AM

  • Helpful answers
  • All replies
first Previous Page 7 of 7
  • by lmzrsk,

     lmzrsk Sep 22, 2015 10:28 AM in response to Flip_Cub
    Level 1 Level 1 (0 points)
    Sep 22, 2015 10:28 AM in response to Flip_Cub

    I've been watching this track for awhile and was having the same issues.  I went after the problem in a step-by-step way.

     

    First, the nano.  Firmware 1.03 was my problem.  I was shutting down within a minute of ending a run, and sometimes just at random.  I saw v1.04 and hoped that would correct the issue.  And, for me, it did not.  So, I went back to v1.02 and now the nano works perfectly.  Again, my experience.  I did the downgrade myself after finding the firmware on an apple focused website.

     

    I also own an iPhone 5 that I started to use.  But, when I upgraded to ios9, I didn't know that the Built-in Nike+ app was removed.  And, for those who suggest Nike Running..... doesn't do the same thing, especially on a treadmill.  So, if you have a iPhone/Touch 4S->5S, don;t upgrade to ios9, if you want the Nike+ App (again, not Nile Running - no sensor data).

     

    So, now I have an iPhone that I can't use for treadmilling, so I took a look around and finally bought an Adidas Speed_cell. It is a BTLE stride sensor that works like Nike+ fob.  Works great with Adidias software, and for Nike fans, use the Wahoo running software, takes to the Speed_Cell and transfer to Nike+.

     

    That is my experience.  I wanted to share it. 

    Sep 22, 2015 10:28 AM

  • by ekoehnrn32,

     ekoehnrn32 Oct 6, 2015 8:13 AM in response to Flip_Cub
    Level 1 Level 1 (0 points)
    Oct 6, 2015 8:13 AM in response to Flip_Cub

    Just got the 7th generation for my birthday in August, and have had consistent shut downs for almost every run. I do have the spoken feedback on, but I love having it-what can I do to keep the feedback on and not have it shut down??!!

    Oct 6, 2015 8:13 AM

  • by bloodfool0,

     bloodfool0 Nov 25, 2015 8:11 PM in response to Flip_Cub
    Level 1 Level 1 (0 points)
    Nov 25, 2015 8:11 PM in response to Flip_Cub

    It's also happening to me. Frustrating knowing that Apple is aware of this issue for some time but has yet to solve it.

     

    I love Apple products, but now I feel that they're getting too good for themselves. There were other issues related to other Apple Support services, which I'm not going to repeat here, but my previously positive views on Apple Support have now been somewhat tarnished.

    Nov 25, 2015 8:11 PM

  • by mj_mj,

     mj_mj Dec 2, 2015 1:01 AM in response to Flip_Cub
    Level 1 Level 1 (0 points)
    Dec 2, 2015 1:01 AM in response to Flip_Cub

    Hi Flip_Club and everyone out there,

     

    Thanks for setting up this thread and posting - I'm very glad and somewhat relieved that there are others out there with a common issue for 7th Gen ipods.


    I'm from New Zealand and am an avid runner. I got the ipod as a xmas present December 2014, after my 6th Gen iPod power button got stuck (a whole other issue right there btw). I was a fan of using my ipod for the inbuilt fitness app so was real excited to get a brand new one and get underway with running with it.

     

    My heart sank once my ipod cut out/shut down while using the fitness app. Multiple times. My ipod has saved only 3 runs but I've done more than that. It's really disheartening to lose data/record of your run (also a mood-killer) and not be able to keep track or beat your personal best. Quite quickly I lost confidence in the ipod and the brand and stopped using it ever since. 

     

    I'm just hoping that Apple come out sooner with a software update to rectify this glitch.

    Dec 2, 2015 1:01 AM

  • by encrypten,

     encrypten Jan 20, 2016 5:41 AM in response to mj_mj
    Level 1 Level 1 (0 points)
    Jan 20, 2016 5:41 AM in response to mj_mj

    Hi everyone from Puerto Rico.

     

    Yesterday schedule a run of 51 minutes. Missing a single minute the iPod automatically turned off. Have any update of this issue?

    Jan 20, 2016 5:41 AM

  • by tim vienna,

     tim vienna Jan 25, 2016 2:48 PM in response to Flip_Cub
    Level 1 Level 1 (0 points)
    Jan 25, 2016 2:48 PM in response to Flip_Cub

    Hi all,

     

    Same issue here with my nano 7th gen: When I replaced my trusted 6th gen with it, everything looked good until during my first runs it happened repeatedly that the iPod would crash and no run was recorded. After some web search I found this thread and discovered that my problem is not an isolated case.

     

    My solution was to downgrade the iPod nano 7th gen to firmware 1.0.2 and it works much better now, no more crashes. I found the source to the old firmware and instructions to downgrade online. I believe I used this link: http://forums.ilounge.com/ipod-nano/276450-ipod-nano-7th-generation-firmware-lin k.html
    Worked well.

     

    But I still have another issue with the iPod and the connection to my Nike+ shoe sensor: When placed in a back pocket the iPod tends to lose contact with the foot sensor and no speed/steps are recorded. Was much better and stable with my 6th gen nano. But that's another story...

    Jan 25, 2016 2:48 PM

  • by jstamos,

     jstamos Jan 27, 2016 4:33 PM in response to tim vienna
    Level 1 Level 1 (0 points)
    Jan 27, 2016 4:33 PM in response to tim vienna

    Hi tim - are there any instructions to install 1.0.2?

    Jan 27, 2016 4:33 PM

  • by tim vienna,

     tim vienna Jan 28, 2016 3:17 PM in response to jstamos
    Level 1 Level 1 (0 points)
    Jan 28, 2016 3:17 PM in response to jstamos

    Hi jstamos,

    Have a look at these 2 threads:

    Downgrading your iPod (tested from 1.1.3 > 1.0.3, Nano 3G, iTunes8, Vista)

    How to downgrade 5G firmware from 1.3

    This basically describes the process I followed.
    Hope this helps!

    Jan 28, 2016 3:17 PM

  • by jstamos,

     jstamos Jan 28, 2016 4:17 PM in response to tim vienna
    Level 1 Level 1 (0 points)
    Jan 28, 2016 4:17 PM in response to tim vienna

    Hi Tim,

    Thanks for those links - but unfortunately haven't had any luck downgrading the firmware


    I have an ipod nano 7th generation with the latest version of itunes installed on Windows 10.

    I have 2 versions of firmware in C:\Users\{username}\AppData\Roaming\Apple Computer\iTunes\Ipod Software Updates:

     

    1) The latest version that itunes downloads that shuts down during run:

    iPod_1.1.1_39A00025.ipsw

    iPod_1.1.1_39A00025.ipsw.signature

     

    2) The older version I have downloaded manually and would like to downgrade to:

    iPod_1.0.2_37A20067.ipsw

    iPod_1.0.2_37A20067.ipsw.signature

     

    The problem is that itunes refuses to install the older version 1.0.2...

     

    I have tried:

    • holding shift and clicking on Restore Ipod..
    • selecting iPod_1.0.2_37A20067.ipsw

     

    But I get error: "The ipod could not be restored because the firmware file is not compatible"

     

    I have also tried removing the new version from the updates folder, disconnecting my internet connection and clicking restore, but no luck.

     

    ...I am starting to regret the day I put my previous ipod through the washing machine.


    Its frustrating that after logging 3000+ kilometers without a problem I start getting this. Apple really need to fix the bug...

    Jan 28, 2016 4:17 PM

  • by tim vienna,

     tim vienna Feb 2, 2016 11:51 AM in response to jstamos
    Level 1 Level 1 (0 points)
    Feb 2, 2016 11:51 AM in response to jstamos

    That's actually interesting. For my generation 7 nano the latest firmware is 1.0.4.
    iTunes also tells me that 1.0.4 would be the latest for my model. (I am on Mac, but that shouldn't make a difference.)
    Do you maybe have one of the newer 2015 7G models? Maybe there were some slight changes so it uses a different firmware? If this is indeed the case and it was shipped with 1.1.1, possibly there is no older version that it accepts. Hopefully someone could help you shed some light on the firmware version topic...


    That would be a bummer, since the latest firmware seems to have this resetting bug

    Feb 2, 2016 11:51 AM

  • by ScottyScottyScott,

     ScottyScottyScott Mar 18, 2016 3:46 PM in response to Flip_Cub
    Level 1 Level 1 (4 points)
    Mar 18, 2016 3:46 PM in response to Flip_Cub

    This defect is frustrating as ****. Clearly well documented. Apple refuses to spend money to fix it -> probably because iPod nano is no longer the money spinner it once was. So many little frustrating usability defects creeping in all their platforms... IOS, OS X... I am heavily invested in Apple products but if they don't get their act together soon I might start to gravitate away..

     

    Why release a new firmware and not fix this bug?

    Mar 18, 2016 3:46 PM

  • by sonyaswim,

     sonyaswim Apr 6, 2016 3:09 AM in response to Flip_Cub
    Level 1 Level 1 (4 points)
    expertise.ipod
    iPod
    Apr 6, 2016 3:09 AM in response to Flip_Cub

    I received my new nano for xmas 2016 and every time I use a custom Time or distance run, the iPod shuts down.  I also lose all run data, both issues are a real pain and causing frustration...,,,Apple, you need to adresss this asap or recall our affected ipods as they are currently not fit for use!

    Apr 6, 2016 3:09 AM

  • by lisafromchristchurch,

     lisafromchristchurch Oct 21, 2016 7:18 PM in response to Flip_Cub
    Level 1 Level 1 (4 points)
    Oct 21, 2016 7:18 PM in response to Flip_Cub

    OK, so finding this thread has been awesome.

    For over a year now, I thought it was something I was doing... Like accidentally hitting the side button when holding it waiting for that last minute to go by.

    doesnt seem to happen on a basic, but does if I set the distance.

    now trying to figure out how to install 1.02.... Wish me luck.  I suspect that the swear jar will be full by the time I am done (I'm tech challenged. Hence why I thought it was my fault and not the device/software)

    Oct 21, 2016 7:18 PM

  • by Mediumroar,

     Mediumroar Jun 20, 2017 9:25 PM in response to Flip_Cub
    Level 1 Level 1 (4 points)
    Jun 20, 2017 9:25 PM in response to Flip_Cub

    My wife just mentioned this to me today and I thought I would investigate. How disappointing to find that this is still an issue after 3 years. I have downgraded her to 1.0.2 in hopes that she can use the Nano 7G for the express purpose that it was purchased. I understand that Nanos aren't a cash cow anymore, but how much software development time would it really take to release an update for these to work properly with the voice feedback enabled?

    Jun 20, 2017 9:25 PM

first Previous Page 7 of 7