Q: Updates Won't Download via App Store

For quite some time, one of my computers has been unable to download the Available Updates it shows.

 

I can click on Update and for just a moment it displays a progress bar and "Calculating...", then it switches back to displaying the Update button. It is not downloading in the background because I can then let it sit for hours and nothing changes.

 

I was able to install El Capitan by downloading it seperately and installing it. Last week, I resorted to downloading the Combo Update, then I reinstalled El Capitan. Still the updates won't load.

 

I've tried Safe Mode, Root User log in, etc. I've repaired Permsisions, run utilities, toggled App Store Prefs... I still get the very same result.

 

Currently I can't get it to install the El Capitan Recovery Update 1.0 and can't find a separate download.

 

It's not a problem in my account because I can install updates on my other Macs without a hitch.

 

How do I fix this??

Mac Pro (Early 2009), OS X El Capitan (10.11)

Posted on Dec 13, 2015 5:15 AM

  • Helpful answers
  • All replies
  • by Toby196,

     Toby196 Dec 14, 2015 3:15 PM in response to James Cook2
    Level 1 Level 1 (24 points)
    expertise.macosx
    Mac OS X
    Dec 14, 2015 3:15 PM in response to James Cook2

    I'm having the exact same problem on the iMac I recently upgraded to El Capitan, and have tried all the same possible solutions you have (with the same unsuccessful results).  For both El Capitan updates (10.11.1 and 10.11.2), my only solution both times was to restart in Recovery Mode and reinstall El Capitan (which included the latest updates).  Unfortunately that did not work for the "El Capitan Recovery Update 1.0" which is still showing as an available update in the App Store.  It also didn't work for the latest iTunes update, which I had to download and completely reinstall the latest version of iTunes to get it up to date.

     

    Anyway, hopefully someone comes along with a solution to this problem, as it is getting quite annoying.

    Dec 14, 2015 3:15 PM

  • by Mnkbsnss,

     Mnkbsnss Dec 14, 2015 3:32 PM in response to James Cook2
    Level 1 Level 1 (40 points)
    Dec 14, 2015 3:32 PM in response to James Cook2

    Hey,

    Have you tried to deauthorize your device (Store>Reauthorize This Computer), log out and log back into the App Store? Not related to the account per se, but to the link between account and machine.

    It might also be a Spotlight Indexing issue, try System Preferences>Spotlight>Privacy Tab>Remove - your startup volume (Macintosh HD) if present in the window.

     

    Hope it helps, Good luck!

    Dec 14, 2015 3:32 PM

  • by Toby196,Apple recommended

     Toby196 Dec 14, 2015 5:11 PM in response to James Cook2
    Level 1 Level 1 (24 points)
    expertise.macosx
    Mac OS X
    Dec 14, 2015 5:11 PM in response to James Cook2

    I think I found a solution from Linc Davis in another thread (Click Here).  To quote the solution:

    This procedure will delete certain temporary and cache files used by system processes. The files are automatically generated and don't contain any of your data. Occasionally they can become corrupt and cause problems such as yours.

    Back up all data and read this whole message before doing anything.

    Triple-click anywhere in the line below on this page to select it:

    /var/folders/zz

    Right-click or control-click the highlighted line and select

              Services Reveal in Finder (or just Reveal)

    from the contextual menu.* A folder should open with a subfolder named "zz" selected. Move that subfolder to the Trash. You may be prompted for your administrator login password. Restart the computer and empty the Trash.

    I followed the direction precisely, except that after highlighting the "/var/folders/zz", right clicking on the highlighted line (to view the context menu) did not give me the options of "Services..." listed above, so I instead had to click on "Firefox > Services > Reveal In Finder" on the web browser's toolbar, then continue on with the rest of Linc Davis' instructions.  As soon as I did so, then restarted the computer, and emptied the trash, I opened the App Store, crossed my fingers, and clicked on "Update All", and joy of joys, it actually started downloading and installing!  I'm really excited and relieved to have this problem solved.

     

    I hope this solution works for you too, James Cook2.  I'm guessing it will, since your problem sounds like it is identical to the problem I was having.  Good luck.

    Dec 14, 2015 5:11 PM

  • by jt519,

     jt519 Dec 16, 2015 3:51 PM in response to Toby196
    Level 2 Level 2 (295 points)
    Dec 16, 2015 3:51 PM in response to Toby196

    I'm seeing the same problem trying to update with the latest "Digital Camera RAW Compatibility Update 6.18". Clicking the Update button just greys out for a second then nothing.

     

    I had seen the "answer" related above, but I do not see a /var/folders/zz directory...

     

    I am seeing SoftwareUpdate related errors in the console:

     

    softwareupdated(444) deny system-fsctl 0x682f

     

     

    Process:        softwareupdated [444]

    Path:            /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated

    Load Address:    0x10480f000

    Identifier:      softwareupdated

    Version:        ??? (???)

    Code Type:      x86_64 (Native)

    Parent Process:  launchd [1]

     

     

    Date/Time:      2015-12-16 18:47:30.232 -0500

    OS Version:      Mac OS X 10.11.2 (15C50)

    Report Version:  8

     

     

    Thread 0:

    0  libsystem_kernel.dylib        0x00007fff9d21fba6 fsctl + 10

    1  Foundation                    0x00007fff9c6921f9 -[NSFileManager _URLForReplacingItemAtURL:error:] + 1748

    2  Foundation                    0x00007fff9c664b7d _NSCreateTemporaryFile_Protected + 201

    3  Foundation                    0x00007fff9c66445e _NSWriteDataToFileWithExtendedAttributes + 232

    4  Foundation                    0x00007fff9c6af2be -[NSArray(NSArray) writeToFile:atomically:] + 226

    5  SoftwareUpdate                0x00007fff9e5224cb -[SUMetadataCache writeCacheToDisk] + 77

    6  SoftwareUpdate                0x00007fff9e547993 -[SUScan _scanMain:] + 1644

    7  SoftwareUpdate                0x00007fff9e54a7f0 -[SUScan performSynchronousScan] + 111

    8  SoftwareUpdate                0x00007fff9e540951 __276-[SUScanController refreshAvailableProductsInForeground:limitedToChanged:evenIfConfigurationChange d:initiatedByDeviceConnection:limitedToProductKeys:forCurrentConfiguration:distr ibutionEnvironment:distributionEvalutionMetainfo:installedPrinters:preferredLoca lizations:finish:]_block_invoke285 + 772

    9  libdispatch.dylib            0x00007fff9c3e2871 _dispatch_call_block_and_release + 12

    10  libdispatch.dylib            0x00007fff9c3d733f _dispatch_client_callout + 8

    11  libdispatch.dylib            0x00007fff9c3dbf6f _dispatch_queue_drain + 754

    12  libdispatch.dylib            0x00007fff9c3e263b _dispatch_queue_invoke + 549

    13  libdispatch.dylib            0x00007fff9c3d733f _dispatch_client_callout + 8

    14  libdispatch.dylib            0x00007fff9c3db1cf _dispatch_root_queue_drain + 1890

    15  libdispatch.dylib            0x00007fff9c3daa34 _dispatch_worker_thread3 + 91

    16  libsystem_pthread.dylib      0x00007fff8d55a68f _pthread_wqthread + 1129

    17  libsystem_pthread.dylib      0x00007fff8d558365 start_wqthread + 13

     

     

    Binary Images:

        0x7fff8d557000 -    0x7fff8d560ff7  libsystem_pthread.dylib (138.10.4) <327cecd0-b881-3153-8fcc-4fd4818b7f16> /usr/lib/system/libsystem_pthread.dylib

        0x7fff9c3d5000 -    0x7fff9c402fff  libdispatch.dylib (501.20.1) <324c9189-2af3-3356-847f-6f4ce1c6e901> /usr/lib/system/libdispatch.dylib

        0x7fff9c5d8000 -    0x7fff9c92cff7  com.apple.Foundation (6.9 - 1256.1) <66106cc9-9d97-3846-88d8-4bf6bb508296> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

        0x7fff9d208000 -    0x7fff9d226fff  libsystem_kernel.dylib (3248.20.55) <0e688457-4915-36dd-8798-5c2edee3f1a3> /usr/lib/system/libsystem_kernel.dylib

        0x7fff9e4f4000 -    0x7fff9e58eff7  com.apple.SoftwareUpdate.framework (6 - 790) <a4c2e56e-4554-3b6a-acac-5a969bc3f0fd> /System/Library/PrivateFrameworks/SoftwareUpdate.framework/Versions/A/SoftwareU pdate

    Dec 16, 2015 3:51 PM

  • by Vyacheslav UA,

     Vyacheslav UA Jun 15, 2016 4:51 PM in response to James Cook2
    Level 1 Level 1 (9 points)
    Jun 15, 2016 4:51 PM in response to James Cook2

    DO NOT move /var/folders/zz to the Trash!

    Delete only the directory which is owned by user _softwareupdate, in my case it is /var/folders/zz/zyxvpxvq6csfxvn_n00000s0000068

     

    workaround-for-osx.png

    Jun 15, 2016 4:51 PM